Multicast - NX-OS and IOS config comparison
Multicast is implemented with different syntax on a Cisco Nexus devices running the NX-OS software, and Cisco devices running the IOS software. The differences are not in the actual operation of multicast, but only in the method of implementation of the configurations.
The following tables indicate some of the major configuration differences between the two operating systems.
Enabling multicast
Cisco IOS | Cisco NX-OS |
---|---|
ip multicast-routing | There is no single global command to enable multicast |
Enabling PIM
This is how to enable Protocol Independent Multicast (PIM).
Cisco IOS | Cisco NX-OS |
---|---|
PIM cannot be enabled or disabled on IOS | feature pim |
Configuring PIM Sparse Mode
Cisco IOS | Cisco NX-OS |
---|---|
interface GigabitEthernet1/1 | interface Ethernet1/1 |
ip address 192.168.1.1 255.255.255.0 | ip address 192.168.1.1/24 |
ip pim sparse-mode | ip pim sparse-mode |
Configuring PIM Auto-RP
Cisco IOS | Cisco NX-OS |
---|---|
interface Loopback5 | interface Loopback5 |
ip address 172.16.10.1 255.255.255.255 | ip address 172.16.10.1/32 |
ip pim sparse-mode | ip pim sparse-mode |
ip pim send-rp-announce Loopback5 scope 32 | ip pim auto-rp rp-candidate Loopback5 group-list 224.0.0.0/4 |
ip pim send-rp-discovery Loopback5 scope 32 | ip pim auto-rp mapping-agent Loopback5 |
ip pim autorp listener | ip pim auto-rp forward listen |
OR | |
ip pim send-rp-announce Loopback5 group-list 224.0.0.0/4 | |
ip pim send-rp-discovery Loopback5 | |
ip pim auto-rp forward listen |
Configuring PIM BSR RP
Cisco IOS | Cisco NX-OS |
---|---|
interface Loopback5 | interface Loopback5 |
ip address 172.16.10.1 255.255.255.255 | ip address 172.16.10.1/32 |
ip pim sparse-mode | ip pim sparse-mode |
ip pim bsr-candidate Loopback5 | ip pim bsr bsr-candidate Loopback5 |
ip pim rp-candidate Loopback5 | ip pim bsr rp-candoidate Loopback5 group-list 224.0.0.0/4 |
ip pim bsr forward listen | |
OR | |
ip pim bsr-candidate Loopback5 | |
ip pim rp-candidate Loopback5 group-list 224.0.0.0/4 | |
ip pim bsr forward listen |
Configuring PIM Static-RP
Cisco IOS | Cisco NX-OS |
---|---|
ip pim rp-address 10.10.10.1 | ip pim rp-address 10.10.10.1 |
Configuring PIM Anycast-RP using BSR
Cisco IOS | Cisco NX-OS | |
---|---|---|
interface Loopback5 | ||
ip address 172.16.10.1/32 | ||
ip pim sparse-mode | ||
interface Loopback6 | ||
description Anycast-RP-Address | ||
Cisco IOS does not support the PIM Anycast RP feature | ip address 192.168.10.1/32 | |
ip pim sparse-mode | ||
ip pim bsr bsr-candidate Loopback5 | ||
ip pim bsr rp-candidate Loopback 6 group-list 224.0.0.0/4 | ||
ip pim anycast-rp 192.168.10.1 172.16.10.1 | ||
ip pim anycast-rp 192.168.10.1 172.16.10.2 | ||
ip pim bsr forward listen |
Configuring PIM neighbor authentication
Cisco IOS | Cisco NX-OS |
---|---|
interface Ethernet1/1 | |
Cisco IOS does not support neighbor authentication | ip address 172.16.10.1/24 |
ip pim sparse-mode | |
ip pim hello-authentication ah-md5 3 a667d47acc18ea6b |
Configuring PIM BSR border on an interface
Cisco IOS | Cisco NX-OS |
---|---|
interface GigabitEthernet1/1 | interface Ethernet1/1 |
ip address 172.16.10.1 255.255.255.0 | ip address 172.16.10.1/24 |
ip pim bsr-border | ip pim sparse-mode |
ip pim sparse-mode | ip pim border |
ip multicast boundary 10 | |
access-list 10 deny 224.0.1.39 | |
access-list 10 deny 224.0.1.40 | |
access-list 10 permit 224.0.0.0 15.255.255.255 |
Configuring an IGMP snooping querier for a particular VLAN
Cisco IOS | Cisco NX-OS |
---|---|
interface vlan 10 | vlan 10 |
ip address 192.168.20.1 255.255.255.0 | ip igmp snooping querier 192.168.20.1 |
igmp snooping querier |